Degraded Insights Performance

Incident Report for Pagos

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 22:33 UTC

Investigating

Data is currently slow to load within the Pagos insights dashboard. Pagos engineers are investigating the root cause of the issue.
Posted Feb 26, 2026 - 20:54 UTC
This incident affected: Pagos Dashboard.