Delays in Data Ingestion

Incident Report for Pagos

Resolved

This incident has been resolved.
Remaining delays for the Braintree processor will be cleared within the next hour.
Posted Jan 21, 2026 - 01:27 UTC

Identified

The engineering team have identified the root cause and are taking steps to mitigate the delays in data ingestion.
Posted Jan 20, 2026 - 15:36 UTC
This incident affected: Pagos Dashboard.