Delays in Data Ingestion for certain batch processors

Incident Report for Pagos

Resolved

This incident has been resolved.
Posted Feb 28, 2026 - 00:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2026 - 21:41 UTC

Identified

The engineering team has identified the root cause and is taking steps to reduce data ingestion delays. The issue primarily affects certain batch processors, including Dlocal, Chase, and PayPal, and is limited to recent data.
Posted Feb 27, 2026 - 14:08 UTC
This incident affected: Data Platform (Batch Data Ingestion).