Pagos Dashboard Unavailable

Incident Report for Pagos

Resolved

This incident has been fully resolved.
All systems are operating normally, and the backlog of data has been completely processed.
Posted Oct 21, 2025 - 21:46 UTC

Monitoring

Our systems are fully operational again. Some file-based connections are still processing a backlog of data, which we expect to be cleared within the next few hours.
Posted Oct 21, 2025 - 15:56 UTC

Update

We’re continuing to work with our third-party vendor to fully resolve the incident. The web application is currently operating normally, but we’re still experiencing delays with data received during the disruption. Our team is actively processing the backlog of data and will share another update as soon as more information becomes available.
Posted Oct 21, 2025 - 07:15 UTC

Identified

Pagos Dashboard is unresponsive due to a provider-related issue. Our team is actively monitoring the situation and will provide updates as soon as they are available.
Posted Oct 20, 2025 - 13:16 UTC
This incident affected: Pagos Dashboard and Pagos Copilot.