Increased data latency for Insights integrations

Incident Report for Pagos

Resolved

The latency issue affecting several data integrations in the Insights section has been fully resolved.
All systems are operating normally.
Posted Sep 11, 2025 - 20:27 UTC

Identified

We've identified the issue and the latency is going down. We'll update here as it progresses.
Posted Sep 11, 2025 - 18:21 UTC

Investigating

We are currently experiencing longer latencies than normal for several data integrations in the insights section. Our engineering team is actively investigating the issue.
Posted Sep 11, 2025 - 17:33 UTC
This incident affected: Data Platform (Batch Data Ingestion).