Degraded performance for some Insights charts

Incident Report for Pagos

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 21:39 UTC

Monitoring

We’ve implemented mitigations and are seeing performance for Insights charts normalizing. Most charts are loading within expected times again.
We’ll continue monitoring closely to ensure performance remains steady and will provide another update if anything changes.
Posted Nov 25, 2025 - 19:56 UTC

Identified

We’re investigating an issue causing degraded performance for a subset of charts in Insights.
Users may notice charts taking longer than usual to load, intermittently failing to render, or timing out.
Our team is actively working to identify the root cause and restore normal performance.
We’ll provide another update within the next 30–60 minutes or sooner if we have new information.
Posted Nov 25, 2025 - 19:26 UTC
This incident affected: Pagos Dashboard.