Network Tokenization Latency

Incident Report for Pagos

Resolved

Issue has been resolved and latency has returned to normal.
Posted Jul 01, 2025 - 21:44 UTC

Monitoring

Remediation has been deployed and we are watching for latency to return to normal
Posted Jul 01, 2025 - 21:30 UTC

Update

Remediation has been deployed and we are watching for latency to return to normal
Posted Jul 01, 2025 - 21:29 UTC

Identified

We have observed latency in network tokenization calls and identified the issue and in process of remediating the issue.
Posted Jul 01, 2025 - 21:16 UTC
This incident affected: Developer Platform (Network Tokenization).