Bin Data, Network Tokenization, and Account Updater services have been recovered and are under active monitoring. We’re still seeing performance degradations in Ingestion Services and Insights, and our team is continuing to work toward full recovery.
We’ll share additional updates as systems stabilize.
Posted Oct 20, 2025 - 09:45 UTC
Identified
We’re currently experiencing a platform-wide service disruption caused by a third-party provider issue, which is affecting parts of our product suite - including Insights, Bin-Data, Network Tokenization, Account Updater, as well as Ingestion Service
We’ll continue to share updates here as we learn more.
Posted Oct 20, 2025 - 07:30 UTC
This incident affected: Developer Platform (Network Tokenization, Real-Time Account Updater, Batch Account Updater, BIN Service), Pagos Dashboard, Pagos Copilot, and Data Platform (Ingestion and Enrichment API, Batch Data Ingestion, Data Export Service, Alerts Service).