Increased data latency for Insights integrations.

Incident Report for Pagos

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 18:05 UTC

Identified

We're experiencing delays with data integrations in the Insights section.
Our team is investigating and working to resolve this.
Posted Jan 23, 2026 - 15:22 UTC
This incident affected: Pagos Dashboard.