Pagos

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Service distribution
Resolved·Partial outage

This incident has been resolved.

Thu, Feb 19, 2026, 06:41 PM
(4 months ago)
·
Affected components
Feb 19, 2026, 04:28 PM
05:15 PM
Dashboard
Pagos AI
Updates

Resolved

This incident has been resolved.

Thu, Feb 19, 2026, 06:41 PM

Monitoring

Our third-party providers have implemented a fix and we're monitoring the results.

Thu, Feb 19, 2026, 05:15 PM(1 hour earlier)

Identified

We are continuing to work on a fix for this issue.

Thu, Feb 19, 2026, 05:01 PM(13 minutes earlier)

Identified

We're currently experiencing a service disruption caused by an issue with one of our third-party providers.Our team is actively monitoring the situation and working with the provider to restore full service as quickly as possible.

Thu, Feb 19, 2026, 04:28 PM(32 minutes earlier)