Increased data latency for Insights integrations.

Incident Report for Pagos

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 16:25 UTC

Identified

We're experiencing delays with data integrations in the Insights section.
Our team have identified the issue and are working to resolve it.
Posted Mar 05, 2026 - 14:55 UTC
This incident affected: Pagos Dashboard.