Pagos

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Increased data latency for Insights integrations.
Resolved·Degraded performance

This incident has been resolved.

Wed, Mar 25, 2026, 02:33 PM
(3 months ago)
·
Affected components
Mar 25, 2026, 01:03 PM
02:33 PM
Dashboard
Updates

Resolved

This incident has been resolved.

Wed, Mar 25, 2026, 02:33 PM

Identified

We're experiencing delays with data integrations in the Insights section for Adyen connectionsOur team has identified the issue and is working to resolve it.

Wed, Mar 25, 2026, 01:03 PM(1 hour earlier)