Pagos

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Data delays in Pagos Dashboard
Resolved·Degraded performance

The latency across all data connections is now back to normal.

Wed, Jun 3, 2026, 01:53 AM
(3 weeks ago)
·
Affected components
Jun 2, 2026, 08:55 PM
Jun 3, 2026, 01:53 AM
Dashboard
Updates

Resolved

The latency across all data connections is now back to normal.

Wed, Jun 3, 2026, 01:53 AM

Monitoring

A fix has been implemented, and we're seeing the data latency go down. We'll keep actively monitoring the latency until it's back to normal.

Tue, Jun 2, 2026, 09:37 PM(4 hours earlier)

Identified

The issue has been identified and a fix is being implemented.

Tue, Jun 2, 2026, 09:02 PM(34 minutes earlier)

Investigating

We're currently seeing data delays in the Pagos Dashboards for all processors. The engineering team is investigating the the issue

Tue, Jun 2, 2026, 08:55 PM