Increased Data Latency for Insights Integrations

Incident Report for Pagos

Resolved

Data ingestion delays are resolved.
Posted Nov 11, 2025 - 19:57 UTC

Investigating

We are currently experiencing longer-than-normal delays with multiple data integrations in the insights section.
Our engineering team is actively investigating the issue.
Posted Nov 11, 2025 - 17:21 UTC
This incident affected: Pagos Dashboard.